Let's Encrypt Certificate Issue: mozilla_pkix_error_required_tls_feature_missing

Incident Report for Hypernode

Resolved

The recent Let's Encrypt change that disrupted our certificate renewal process has been fully resolved platform-wide. Users should no longer experience issues, including the mozilla_pkix_error_required_tls_feature_missing error or problems requesting new certificates via Hypernode Manage vhosts.

If you continue to encounter any issues, please reach out to support.
Posted Feb 04, 2025 - 12:17 CET

Update

We are continuing to work on a fix for this issue.
Posted Feb 04, 2025 - 11:13 CET

Identified

Let's Encrypt recently implemented a change that disrupted our certificate renewal process for Let's Encrypt certificates. We have implemented a fix and are working on a platform-wide resolution.

Possible errors include mozilla_pkix_error_required_tls_feature_missing and occasional issues when requesting a new certificate via Hypernode Manage vhosts.
Posted Feb 04, 2025 - 11:13 CET
This incident affected: Third-Party Service Providers.